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Languages in non-Roman scripts

School facilities

A simple rationale
Teachers need access to word-processing facilities in their language to enable them to 
create high-quality resources, both for use as paper-based worksheets and as interactive 
resources for use on a computer. 

ICT offers appeal to a wider range of learning styles, through its facilities of text, image, 
colour, animation, audio and video, for example. It can enhance significantly whole-class 
teaching, through motivation, focus and/or support. It can bring the outside world into 
the classroom through the use of websites, video, audio or digital photographs. The new 
secondary curriculum also regards the use of ICT by pupils as a functional skill and 
“fundamental to learning across the curriculum”; as such it is embedded in the programme of 
study for modern foreign languages. 

Schools should aim to give pupils access to word-processing in the language they are 
studying, both in lesson time and outside of lessons. Word-processing enables them to 
develop language through drafting on-screen and amending and refining their work to 
enhance its quality and accuracy. Word-processed text can be used in other programs such 
as PowerPoint, email and web publishing, contributing to many aspects of the languages 
curriculum.

Your language may be a recent addition to the subjects offered and/or you may be the 
only teacher. It may even be taught outside of the core curriculum, to only a small number 
of pupils or outside of the school day. High quality resources are important to ensure the 
status of your language in the eyes of pupils, parents and colleagues and, hopefully, its 
continuing provision. Where you are teaching your language as a community language, you 
may need to persuade parents of the value in their children pursuing their study; the ability 
to communicate with parents in their own home language via typewritten letter on school 
headed paper could be beneficial. 

Inputting non-Roman script languages
Many schools have networks of PCs with a Microsoft Windows operating system 
and Microsoft Office software, which includes word-processing (Word), presentation 
(PowerPoint), email (Outlook) and other applications. Versions from 2000 onwards of 
(English) Windows and Office offer the facility to enable many non-Roman script languages, 
such as Arabic, Chinese, Panjabi, Russian and Urdu. Once enabled, you can use Microsoft 
applications in your language, without any effect on the working of the English system. 

This solution is completely free-of-charge and should be the simplest option for most users. 
There are also a number of non-Microsoft solutions available in certain languages, some of 
which are low-cost or free-of-charge. Make sure that your network manager is aware of the 
possibilities; see the Setting up your computer section on the Languages ICT website.

If you cannot type directly in your language into the program you are using (e.g. PowerPoint, 

http://curriculum.qca.org.uk
http://curriculum.qca.org.uk
http://www.languages-ict.org.uk/non_roman/setting.htm
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TaskMagic software), it is unlikely that you will be able to paste in non-Roman script text 
successfully from your word-processing package. However, it is feasible to create a section 
of text in whatever word-processing package you have and then change it into an image file 
in a program such as the free Microsoft Paint (comes with Windows; go to Start > Programs 
> Accessories). Alternatively use a scanner to create picture files of your handwritten or 
typewritten text. 

Keyboard options
It is important to consider how to input the non-Roman script language and which 
keyboard layout to use. Language-specific keyboards may be available in your language 
in an appropriate layout, but this scenario is unlikely in many UK schools and for some 
pupils at home. Keyboard stickers are available in some languages; perhaps less costly 
but still rendering the keyboard language-specific. Keyboard gloves are also available in 
some languages and may provide a more flexible solution. Some software offers an online 
keyboard display. A picture of the language keyboard, such as that for the software Executive 
Punjabi illustrated here, could simply be placed next to the computer. This may not be 
suitable for prolonged computer use, but offers a simple solution for working in UK schools 
with English equipment. Lingua is an example of a distributor which can advise on keyboard 
issues.

Gate Seven Computers Ltd 2004

Some teachers have expressed concerns over the keyboard layout options provided with 
certain software, which may not be appropriate in a UK context. Increasingly, however, there 
are more options to choose from. 

Make sure that your network manager is aware of all possibilities for your language; see the 
Setting up your computer section on the Languages ICT website.

Non-Roman script languages on the web
If the script on a website appears as jumbled symbols, try changing the encoding in your 
browser. For example, if you are using Internet Explorer, go to View > Encoding > More 
and try some of the options given. Whilst paying attention to copyright restrictions, you can 
copy text and images from useful websites you find and paste them into word-processed 
documents, PowerPoint presentations, interactive whiteboard pages etc. You may find that 
some web-based text in non-Roman scripts is actually in picture format, so it can be copied 
and pasted but cannot subsequently be edited in a word-processing package.

Interactive whiteboard technology
If you have access to an interactive whiteboard connected to a data projector, you will have 
access to the software which comes with the board. This will allow you or pupils to hand-write 

http://www.lingua-uk.com
http://www.languages-ict.org.uk/non_roman/setting.htm
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in your language on the board, either with your finger or a special pen, whether labelling an 
image or writing sentences. The bonus of an interactive whiteboard is that you can then save 
your writing in electronic format. It is unlikely that there will be a handwriting recognition tool 
for your language, so most likely the writing will be saved as images; this means you will not 
be able to edit the text further once saved. However, you are still able to use a wide range of 
facilities offered by the software which comes with many interactive whiteboards, such as:

labelling a picturezz

dragging text to match a picturezz

dragging a sentence to match anotherzz

revealing text line by linezz

annotating words in a text with colour circles and underlinezz

revealing parts of a text using a ‘spotlight’ facilityzz

Whole-class teaching without an interactive whiteboard
If you do not have access to an interactive whiteboard, you may still be able to use a data 
projector, which projects anything on your computer screen onto a white surface, whether a 
wall, sheet, board or screen. You can then share resources with pupils which combine text, 
image, colour, animation, audio and video and appeal to different learning styles in a way 
that is not possible without ICT (certainly not combined together!) If there is no data projector 
available, be aware that some TV screens can be connected to a computer.

Some schools, particularly supplementary/complementary schools, may have very limited 
access to ICT facilities. If you have small groups, it may be possible to gather pupils around 
your computer for effective group teaching. You can use large-sized font to improve visibility; 
go to Format > Font in Word, for example, and increase the font point size. Or you can 
increase the percentage view on a document; go to View > Zoom and increase to 150%, for 
example. If you are using a web page, go to View > Text size, which will increase the size of 
text on many web pages (from Medium to Larger or Largest). If that does not work, try View > 
Full Screen. Some websites, such as the CILT website, have their own text size function.

Recording and editing sound and video
Not all ICT requires the use of text. Many teachers are using audio and video technology to 
provide opportunities for pupils to develop their creative use of language. To create an audio 
file, plug a microphone into your computer and go to Start > Programs > Accessories > 
Entertainment > Sound Recorder. Sound Recorder comes as part of the Windows operating 
system and is very easy-to-use as it looks and works like a traditional tape recorder.
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Sound files can then be saved and shared with others; either as stand-alone files or 
embedded into resources such as a PowerPoint presentation. A popular and more 
sophisticated alternative for sound recording and editing is the free, open source software 
Audacity. 

If you have access to a digital video camera, be aware of the free Movie Maker video 
editing program which again comes as part of the Windows operating system. Go to Start > 
Programs. It is a simple program but an ideal place to start.

Do not forget the simple digital stills camera also. Photographs can be used in many ways to 
stimulate and illustrate teaching resources or language work by pupils.

For ideas on using audio, video and digital photos in language lessons, look at the 
Technology for languages and Useful ICT ideas, effective language lessons sections on 
the Languages ICT website. 

Communicating internationally
With heightened focus in both primary and secondary curricula on intercultural 
understanding, it is worth investigating opportunities for pupils to communicate with native 
speakers in the target language country or local community, or with others studying the same 
language. The Global Gateway website from the British Council is an excellent way to find 
a partner school. See the ICT international section of the Languages ICT website for other 
suggestions.

If using email, explore the use of your language script in the email packages you have 
access to and whether your communication partner can open and read messages when they 
arrive the other end. If both partners are using the same Microsoft Office solution, you should 
be able to type and read directly from email messages. Otherwise, you could exchange 
messages in word-processed documents as attachments, if your word-processing packages 
are compatible. Some find that saving a Word document in RTF helps to avoid text turning 
into a nonsense of letters and symbols: go to File > Save As > Save as type – click on the 
downwards arrow and scroll down to Rich Text Format. Other options are to convert a Word 
document to PDF format using free software such as PrimoPDF; or to scan your written 
message and send it as a picture.

If your school has a video-conferencing system, ask if you can use it with your classes as 
you do not need any kind of special software for your language. Be aware that webcams and 
use of free software such as Microsoft NetMeeting have made video-conferencing over the 
web a simple and cost-effective solution. The Global-leap website offers useful information 
for schools exploring video-conferencing.

Creating interactive resources
There are still few examples of web-based interactive exercises in non-Roman script 
languages, but this may well change over the next few years. If you are a teacher of Arabic, 
Panjabi or Tamil, take a look at the GISMO Authoring Package for creating interactive 
activities in script. 

It is usually possible to take advantage of matching exercises within authoring software 
such as Hot Potatoes or TaskMagic. Sound files can be matched with picture files or other 
sound files, for example. Word-processed text can be saved as an image file and matched 
with ‘text’, picture or sound files. It may even be appropriate to use a romanised version 
of your language, of course. Examples in Japaneses can be seen on the Katharine Lady 
Berkeley’s School website. 

It is possible to replicate this kind of interaction, but it can be time-consuming. For example, 

http://audacity.sourceforge.net/
http://www.languages-ict.org.uk/technology/technology.htm
http://www.languages-ict.org.uk/useful_ideas/LinksDatabase.aspx
http://www.globalgateway.org.uk/
http://www.languages-ict.org.uk/ict_inter/ICT_international.htm
http://www.primopdf.com/
http://www.microsoft.com/downloads
http://www.global-leap.com/
http://languages.londonmet.ac.uk/CALL/nonLatin/home.htm
http://hotpot.uvic.ca/
http://www.mdlsoft.co.uk/
http://www.klbschool.org.uk/interactive/index.htm
http://www.klbschool.org.uk/interactive/index.htm
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in a PowerPoint presentation, you can create an interactive listening exercise by inserting 
a clickable sound file, a number of text or picture answers and a clickable sound file next to 
each to tell the pupil whether s/he is right or wrong. In a word-processed document, answers 
can be provided in white font, so pupils just need to highlight and change the font colour to 
read an answer and check whether it matches their own attempt.

Where to look
New secondary curriculum: http://curriculum.qca.org.uk

Languages ICT – Non-Roman scripts: www.languages-ict.org.uk/non_roman/setting.htm

Lingua: www.lingua-uk.com

Audacity: http://audacity.sourceforge.net

Languages ICT – Technology: www.languages-ict.org.uk/technology/technology.htm

Languages ICT – Database: www.languages-ict.org.uk/useful_ideas/LinksDatabase.aspx

Global Gateway: www.globalgateway.org.uk

Languages ICT – ICT international: www.languages-ict.org.uk/ict_inter/ICT_international.htm

Primo PDF: www.primopdf.com

Microsoft Netmeeting download: www.microsoft.com/downloads

Gismo Authoring Package: http://languages.londonmet.ac.uk/CALL/nonLatin/home.htm

Hot Potatoes: http://hotpot.uvic.ca/

Global-leap: www.global-leap.com

TaskMagic: www.mdlsoft.co.uk

Links were correct at time of publication in June 2008.
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